[跟隨大神] Rails 5 環境篇

瀏覽次數:0

沒有財力就用時間學習去補、一定要認真看說明書

xdite的方法是最好的因為保護你的注意力最多.

發現xdite老師在Growth school更新了Rails5.0的資訊了,溫故知新很重要 打算再來自我學習一遍
目標:建好Rails5.0開發要的環境
思考:用4.0的環境改或找尋新平台
考慮:上回學習期間只有在家才能練功, 因為公司電腦沒裝 那麼可能弄在雲端嗎? 可能跨平台存取嗎?
實做:有同學介紹 cloud9 讀了說明書發現真的不錯.
得到:一個在雲端的Rails 5開發環境, 費時2小時.

選擇平台. Rails 4的時代我用vmplayer裝ubuntu, 可以用但無法到哪都可以用, 所以這回改在雲平台上做.

因為沒有mac, 所以選了coud 9 平台.
1. 請看說明書把帳號建好. git帳號可以之後連
2. 即使你申請學術用途仍會需要信用卡資訊.
3. 選用Rails Tutorial建立workspace!

設定Rails環境: 完全沒有概念的人請看RailsBridge Docs就知道需要什麼.

因為要做Rails 5所以先檢查各項環境版本對不對.
1. git指令集:
usage: git --help

2. Ruby版本預設是 ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-linux], 因此安裝 2.3.1. 裝完再次檢查版本就是 ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-linux]
rvm install 2.3.1

3. 安裝 Rails 5.0; 裝完會得到 5.0.0.1 版本
gem install rails -v 5.0.0.1

ImageMagick套件和Postgre SQL

ImageMagick
sudo -i
cd
apt-get install build-essential checkinstall && apt-get build-dep imagemagick -y
wget https://www.imagemagick.org/download/ImageMagick.tar.gz "拿到最新版後把他解開, 像下面這樣"
tar xzvf ImageMagick.tar.gz
cd ImageMagick-7.0.3-10
./configure --prefix=/opt/imagemagick-7.0 && make
make install

Postgre SQL
sudo apt-get update
sudo apt-get install postgresql postgresql-contrib

用Rails 5來建個新的app吧!

rails new rails101

裝完後進入這個路徑: cd rails101
檢查使用的環境版本: rails -v
看到 Rails 5.0.0.1 恭喜你可以進入下一關.

看看你的App!

要在雲端看 指令略有不同要注意:
rails server -b $IP -p $PORT

以上些作業, 翻了之前的筆記線上文章等之後 , 花了我2了小時才做完. 所以時間就是金錢的朋友可以算算看要不要買個Mac

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *